Почта 1С

  • автор:

Как настроить отправку почты из 1С? Как отправлять письма из 1С? Как настроить учетную запись электронной почты 1С? Как отправлять счета на оплату из 1С?

Если вам нужно настроить электронную почту в 1С 8.3, то вы можете воспользоваться инструкцией, представленной на данной странице.

Отправка почты из 1С 8.3 может понадобиться, например, когда нужно отправить счет на оплату клиенту. Для этого нужно настроить учетную запись почты в 1С. Далее, будет расказанно, как это сделать.

Теперь по пунктам распишем, что необходимо предпринять, чтобы отправлять письма из 1С 8.3. Покажем это на примере программы 1С:Бухгалтерия предприятия 3.0, а использоваться будет почта с почтового сервера mail.ru, потому что отправку писем из этого почтового сервиса можно легко настроить в 1С. Имейте в виду, что для настройки отправки писем с других почтовых сервисов (например, gmail.com) могут потребоваться дополнительные действия, которые не описаны в данной статье. Если вам нужно настроить в 1С почту gmail.ru, то перейдите к этой инструкции.

1. Открываем программу 1С. Заходим в Администрирование (1) — Органайзер (2).

2. В разделе Почта выбираем Настройка системной учетной записи.

3. Откроется окно настроек как на картинке ниже.
— Вводим адрес электронной почты, который будет использоваться для отправки писем (1);
— Вводим пароль от учетной записи этой электронной почты (2);
— Выставляем галочку Для отправки почты. Также можно выставить галочку Для получения почты (3);
— Выбираем для кого создавать учетную запись: либо Для всех пользователей, либо Только для меня — для текущего пользователя (4);
— Указываем имя отправителя, которое будет видно получателям. Это может быть название вашей организации (5);
— Ставим переключатель на Настроить параметры подключения вручную, чтобы не пропустить важные моменты процесса настройки (6);
— Теперь нажимаем Далее (7).

5. Появится похожее на предыдущее окно. Только здесь настраивается получение писем.
— Проверим имя пользователя (1);
— Проверим пароль (2);
— В поле Сервер укажем следующий адрес: pop.mail.ru (3);
— В поле выбора Протокол укажем протокол под названием POP (4);
— В поле Порт укажем следующее число: 995 (5);
— Выставим галочку Использовать безопасное соединение (SSL) (6);
— Опять нажимаем Далее (7).

6. В следующем окне можно ничего не менять. Просто жмём Далее.

7. После этого некоторое время будет идти проверка настроек учетной записи. Дождитесь ее окончания.

8. После окончания проверки появится надпись Учетная запись успешно настроена. Нажимаем кнопку Перейти к учетной записи.

9. Удостоверимся, что почта настроена правильно.
— Открываем меню Еще (1);
— Нажимаем на пункт меню Проверить настройки (2);

10. Если все настроено верно, появится окно с надписью «Проверка параметров учетной записи завершилась успешно». Нажимаем ОК (1). Нажимаем Записать и закрыть (2).

Итак, мы настроили учетную запись электронной почты в 1С. Прежде чем что-то отправлять, посмотрим как настроить для отправляемых писем подпись, которая будет выводится в конце текста письма.

11. Перейдем в Главное (1) — Персональные настройки (2).

12. Нажмем на ссылку Настройки электронной почты.

13. Откроется окно настроек.
— В поле выбора «Основная четная запись…» выберем учетную запись, которую мы только что создали, в данном случае это «Системная учетная запись» (1);
— Вы можете поставить галочку Отправлять копии исходящих писем по адресу и указать на какие адреса будут приходить копии, отправленных Вами писем.
— В текстовом поле, вы можете задать, как будет выглядеть подпись к Вашим письмам (2);
— После редактирования, нажимайте ОК (3).

14. Нажмаем «Записать и закрыть» в окне персональных настроек.

Итак, настройка почты завершена! Давайте попробуем отправить кому-нибудь счет на оплату…

15. В документе выбираем кнопку-команду с изображением конверта.

16. В списке печатных форм отметим галочками формы, которые мы хотим отправить контрагенту (1). Для выбора в каком формате отправлять печатную форму, вы можете нажать на ссылку Формат вложений (2);

17. Отмечаем галочками нужный формат (1). Если нужно, выставляем флажок Упаковать в архив (.zip) (2). Нажимаем Выбрать.

18. Вернувшись в окно выбора печатных форм, тоже нажимаем Выбрать.

19. Откроется окно отправки сообщения.
— В поле выбора Кому выбирайте контактное лицо, которому хотите отправить письмо (1);
— В поле Тема указана тема письма. Можно ее отредактировать, как вам нужно. (2);
— Если это необходимо, отредактируйте текст письма (3);
— Можете прикрепить к нему дополнительные файлы (4);
— Наконец, можно нажимать кнопку Отправить (5);

20. Письмо отправлено! Контрагент его получил!

Работа с электронной почтой возможна непосредственно из встроенного языка. Разработчик может выполнять отправку и прием писем электронной почты.

Система 1С:Предприятие 8 предоставляет две возможности работы с электронной почтой: используя почтового клиента, ранее установленного на компьютере, или без использования внешнего почтового клиента.

Интернет-почта (без установленного почтового клиента)

Механизм интернет-почты позволяет организовать обмен электронной корреспонденцией между адресатами, не имея отдельного установленного почтового клиента. Для этого во встроенном языке существует тип ИнтернетПочта. Его описание находится в группе Общие объекты — Почта — ИнтернетПочта.

Универсальность набора объектов этого механизма позволяет решать различные задачи коммерческой деятельности предприятия, связанные с информационным обменом. К таким задачам относятся обмен информацией с клиентами предприятия, рассылка пресс-релизов в медиа-издания, обмен коммерческой информацией с контрагентами и т. д. Решение этих задач упрощается благодаря возможности передавать и получать данные в различных форматах (текст, HTML, графика, двоичные данные и т. д.).

В основе механизма электронной почты лежат общепринятые почтовые Интернет-протоколы SMTP и POP3, что позволяет использовать уже существующие и широко распространенные в Интернете почтовые инфраструктуры, а для пользователей такая опора на известные стандарты сокращает время освоения прикладных решений.

Механизм интернет-почты позволяет:

  • подключаться к почтовому серверу, указывая адреса и параметры протоколов IMAP, POP3 и SMTP;
  • использовать защищённые соединения SSL/TLS и STARTTLS;
  • отключаться от почтового сервера;
  • отправлять почтовые сообщения, в том числе с предварительной обработкой текста сообщения перед отправкой;
  • выбирать сообщения с почтового сервера, в том числе с удалением;
  • удалять сообщения с почтового сервера;
  • создавать новые почтовые сообщения;
  • задавать отправителя сообщения, получателей, копии, тему, текст письма и перечень вложенных файлов;
  • использовать различные типы текста почтового сообщения: HTML, простой текст и размеченный текст (Rich Text);
  • использовать в качестве вложений двоичные данные или другие почтовые сообщения;
  • задавать кодировку как всего сообщения в целом, так и отдельных его элементов;
  • принимать только заголовки сообщений;
  • получать исходные тексты почтовых сообщений, что позволяет строить полноценные email клиенты.

Начиная с версии 8.3.18 во встроенном языке реализована возможность указывать произвольный Content-type для текстов в почтовом сообщении. Благодаря этому можно, например, корректно работать с письмами-приглашениями календарных сервисов и рассылать приглашения, используя интернет-почту.

Почта (требует установленного почтового клиента)

В системе поддерживается взаимодействие с почтовым клиентом, установленным на компьютере. Для этого во встроенном языке существует тип Почта. Его описание находится в группе Общие объекты — Почта — Почта.

С его помощью можно создавать, посылать и принимать сообщения, причем сообщения могут иметь несколько адресатов и присоединенных файлов, добавлять (менять, удалять) адреса как пары (пользователь — сервер), так и полные почтовые адреса, управлять почтовыми вложениями и т. д.

При организации доступа к почтовой системе, установленной на компьютере, имеется возможность:

  • подключаться к почтовому серверу и отключаться от него;
  • посылать сообщения с запросом подтверждения;
  • выбирать непрочитанные сообщения с почтового сервера;
  • создавать новые сообщения;
  • задавать отправителя сообщения, получателей, копии, тему, текст письма и перечень вложенных файлов.

Технологии интеграции 1С:Предприятия 8.3

Авторы: Е.Ю. Хрусталева

В системе 1С есть возможность отправлять электронные письма. Используя встроенные объекты и функции в системе 1C можно отправить письмо на электронную почту. Во многих типовых конфигурациях существуют готовые функции для отправки почты. Чаще всего эти процедуры или функции располагаются в общих модулях.
На многих популярных почтовых серверах отправка почты поддерживается только с использованием технологии шифрования SSL. В системе 1С:Предприятие 8 использование технологии SSL доступно только на платформах не ниже версии 1С:Предприятие 8.3. Более подробную информацию о платформах можно узнать на сайте компании 1c.ru
Адреса, порты популярных почтовых серверов и другие настройки почты, доступны на сайтах поставщиков.

Функция ОтправитьПисьмо()

Функция ОтправитьПисьмо(EmailОтправителя, ПарольОтправителя,
Порт, АдресСервера, EmailПолучателя,
ИмяПолучателя, ТекстСообщения,
ЗаголовокСообщения, МассивФайловыхПутей)
//ПОЧТОВЫЙ ПРОФИЛЬ
Профиль = Новый ИнтернетПочтовыйПрофиль;
Профиль.ИспользоватьSSLSMTP = Истина;
Профиль.АдресСервераSMTP = АдресСервера;
Профиль.ПортSMTP = Порт;
Профиль.Пользователь = EmailОтправителя;
Профиль.Пароль = ПарольОтправителя;
Профиль.АутентификацияSMTP = СпособSMTPАутентификации.ПоУмолчанию;
Профиль.ПарольSMTP = ПарольОтправителя;
Профиль.ПользовательSMTP = EmailОтправителя;
//ПОЧТОВОЕ СООБЩЕНИЕ
Сообщение = Новый ИнтернетПочтовоеСообщение;
Сообщение.Отправитель = EmailОтправителя;
Сообщение.Тема = ЗаголовокСообщения;
Сообщение.Тексты.Добавить(ТекстСообщения, ТипТекстаПочтовогоСообщения.HTML);
Сообщение.Организация = «The company»;
Адрес = Сообщение.Получатели.Добавить(EmailПолучателя);
Адрес.ОтображаемоеИмя = ИмяПолучателя;
Для каждого ПутьКФайлу Из МассивФайловыхПутей Цикл
Сообщение.Вложения.Добавить(ПутьКФайлу);
КонецЦикла;
// ПОЧТОВЫЙ СЕРВЕР
Почта = Новый ИнтернетПочта();
//Подключение к серверу
Попытка
Почта.Подключиться(Профиль);
Исключение
Сообщить(«Ошибка при подключении к серверу: » + ОписаниеОшибки());
Возврат Ложь;
КонецПопытки;
//Отправка письма
Попытка
Почта.Послать(Сообщение);
Исключение
Почта.Отключиться();
Сообщить(«Ошибка при отправке письма: » + ОписаниеОшибки());
Возврат Ложь;
КонецПопытки;
Почта.Отключиться();
Возврат Истина;
КонецФункции

Функция ПолучитьПисьма()

Функция ПолучитьПисьма()
//ПОЧТОВЫЙ ПРОФИЛЬ
Профиль = Новый ИнтернетПочтовыйПрофиль;
Профиль.Пользователь = «xxx@xxxx.xx»;
Профиль.Пароль = «xxxxxx»;
Профиль.АдресСервераPOP3 = «pop3.mail.ru»;
ПРофиль.АутентификацияPOP3 = СпособPOP3Аутентификации.Обычная;
МассивПисем = Новый массив();
//ПОЛУЧЕНИЕ ПИСЕМ
Попытка
Почта = Новый ИнтернетПочта;
Почта.Подключиться(Профиль);
МассивПисем = Почта.Выбрать(Ложь);
Исключение
Сообщить(«Ошибка получения почты » + ОписаниеОшибки());
КонецПопытки;
Возврат МассивПисем;
КонецФункции
В управляемом приложении перед функцией необходимо поставить &НаСервере

Порядок выполнения действий:

  • Заходим в раздел Органайзер и устанавливаем «галочку» Почтовый клиент.
  • Заходим в Настройка системной учётной записи электронной почты.

Откроется окно настройки:

Наименование: Наименование системной учётной записи Федоров

Адрес электронной почты: mail@yandex.ru

Имя отправителя писем: mail@yandex.ru.

Выбираем «галочками» для чего использовать будем ящик: для отправки и для получения писем.

Вкладка Отправка писем

Имя пользователя: mail@yandex.ru

Пароль: ***********

«Галочку» Безопасная проверка пароля снимаем!

Далее вписываем параметры почтового сервера Яндекса

Сервер: smtp.yandex.ru

Порт: 465

Включить «галочку» Использовать безопасное соединение SSL

Вкладка Получение писем

Сервер: pop.yandex.ru;

Порт — 995;

Включить «галочку» Использовать безопасное соединение SSL;

Проверить настройки: Проверка параметров учетной записи завершилась успешно.

В почтовом ящике сообщение: «Это сообщение отправлено подсистемой электронной почты 1С:Предприятие»

Разделение нескольких электронных почт между пользователями 1С для автоматической отправки

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *