Как выгрузить номера телефонов из 1С

  • автор:

1С8. Выгружаем из 1С контактную информацию контрагентов из регистра сведений в CSV-файл

Контактная информация контрагентов почта, адрес, сайт, как правило хранится в 1С в Регистре Сведений.

Информация представлена в виде записей.

Пример выгрузки контактной информации контрагентов из 1С в файл-csv. .

Весь процесс получения файла можно разделить на три шага:

  • Выполним запрос к Регистру сведений — вернем Таблицу Значений
  • Из Таблицы Значений создаем текст CSV файла в виде большой строки -(текст заголовков и текст данных)
  • Текст CSV записываем в обычный текстовый файл с кодировкой ANSI и с расширением .csv (C:\Temp\ki.csv)

На выходе получаем C:\Temp\ki.csv:

// Выполним запрос к регистру сведений // Результат Таблицазначений с контактной информацией контрагентов Функция ПолучитьКонтактнуюИнформациюКонтрагентов() Запрос = Новый Запрос; Запрос.Текст = «ВЫБРАТЬ * |ИЗ | РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация»; Результат = Запрос.Выполнить(); ТаблицаЗначений = Результат.Выгрузить(); возврат ТаблицаЗначений; КонецФункции // // Создаем строку заголвков для CSV-файла. // Цикл по колонкам таблицы значений Функция СоздатьЗаголовкиCSV(ТаблицаЗначений,разделитель) //разделитель = «|»; колонкиТЗ=ТаблицаЗначений.колонки; Для каждого колонка Из колонкиТЗ Цикл стрКолонки = «» + стрКолонки + колонка.Имя + разделитель ; КонецЦикла; Возврат стрКолонки; КонецФункции // Создаем строку записи ТаблицыЗначений для CSV-файла Функция СоздатьСтрокуCSV(записьТаблицаЗначений,разделитель) стрЗапись = «»; Для каждого поле Из записьТаблицаЗначений Цикл стрЗапись = «» + стрЗапись + Строка(поле) + разделитель ; КонецЦикла; Возврат стрЗапись; КонецФункции // Создаем текст CSV: // текст заголовков и // текст данных Функция СоздатьДанныеCSV(ТаблицаЗначений,разделитель) текстЗапись=»»; для каждого запись из ТаблицаЗначений Цикл // начало цикла по строкам таблицы значений // если не сформирована строка CSV с заголовками полей // контактной информации — создаем если текстЗапись=»» тогда текстЗапись=СоздатьЗаголовкиCSV(ТаблицаЗначений,разделитель) + Символы.ПС; КонецЕсли; // для каждой записи создаем строку CSV стрЗапись = СоздатьСтрокуCSV(запись,разделитель); // выводим сообщение в панель состояний Сообщить(запись); Состояние(стрЗапись); текстЗапись = текстЗапись + стрЗапись + Символы.ПС; КонецЦикла; Возврат текстЗапись; КонецФункции // // Запишем данные в файл Функция ЗаписатьCSV(текст,имяФайла) //кодировка = КодировкаТекста.ANSI; кодировка = КодировкаТекста.UTF8; ТекстовыйФайлЗапись = Новый ЗаписьТекста(имяФайла,Кодировка); ТекстовыйФайлЗапись.ЗаписатьСтроку(текст); ТекстовыйФайлЗапись.Закрыть(); Возврат 0; КонецФункции // // Основная логика: Функция ВыгрузитьКонтактную_Информацию_Контрагентов_В_CSV(имяФайлаCSV); сообщить(«Выгрузить Контактную Информацию Контрагентов в формате CSV в » + имяФайлаCSV); разделительCSV = «|»; ТаблицаЗначений = ПолучитьКонтактнуюИнформациюКонтрагентов(); текст = СоздатьДанныеCSV(ТаблицаЗначений,разделительCSV); ЗаписатьCSV(текст,имяФайлаCSV); сообщить(имяФайлаCSV + » -» ); КонецФункции ВыгрузитьКонтактную_Информацию_Контрагентов_В_CSV(«C:\Temp\ki.csv»);

Открыть csv файл можно в текстовом редакторе в виде простого текста или в Excel в виде таблицы.

Замечания на J008@J008.ru

Выгрузка

Смотреть что такое «Выгрузка» в других словарях:

  • Выгрузка — процесс снятия груза, почты, контейнеров и поддонов, буфетно кухонного оборудования с борта воздушного судна после его приземления под наблюдением управомоченных лиц перевозчика. Источник: Руководство по грузовым перевозкам на внутренних… … Словарь-справочник терминов нормативно-технической документации

  • выгрузка — заниматься карманной выгрузкой.. Словарь русских синонимов и сходных по смыслу выражений. под. ред. Н. Абрамова, М.: Русские словари, 1999. выгрузка высаживание, пневмовыгрузка, разгрузка, опорожнение, опоражнивание, паузка, сгрузка. Ant.… … Словарь синонимов

  • ВЫГРУЗКА — ВЫГРУЗКА, выгрузки, мн. нет, жен. Действие по гл. выгрузить выгружать. Выгрузка багажа. Толковый словарь Ушакова. Д.Н. Ушаков. 1935 1940 … Толковый словарь Ушакова

  • выгрузка — ВШЫГРУЗИТЬ, ужу, узишь; уженный; сов., что. Извлечь, вынуть какой н. груз, что н. тяжёлое. В. багаж. Толковый словарь Ожегова. С.И. Ожегов, Н.Ю. Шведова. 1949 1992 … Толковый словарь Ожегова

  • выгрузка — сохранение (данных из ОЗУ в ВЗУ) — Тематики информационные технологии в целом Синонимы сохранение (данных из ОЗУ в ВЗУ) EN roll out … Справочник технического переводчика

  • Выгрузка — – процесс извлечения огнеупора из теплового агрегата после завершения тепловой обработки. Рубрика термина: Технологии керамики Рубрики энциклопедии: Абразивное оборудование, Абразивы, Автодороги … Энциклопедия терминов, определений и пояснений строительных материалов

  • Выгрузка — ж. 1. процесс действия по гл. выгружать, выгрузить, выгружаться 1., выгрузиться 2. Результат такого действия. Толковый словарь Ефремовой. Т. Ф. Ефремова. 2000 … Современный толковый словарь русского языка Ефремовой

  • выгрузка — выгрузка, выгрузки, выгрузки, выгрузок, выгрузке, выгрузкам, выгрузку, выгрузки, выгрузкой, выгрузкою, выгрузками, выгрузке, выгрузках (Источник: «Полная акцентуированная парадигма по А. А. Зализняку») … Формы слов

  • выгрузка — погрузка … Словарь антонимов

  • выгрузка — в ыгрузка, и, род. п. мн. ч. зок … Русский орфографический словарь

Как выгрузить документы из Мое дело в 1С

Я не буду говорить про 60 счет, 75 и не закрытый 26 счет, потому что и так понятно, что предприниматель наверняка как-то криво занес уставной капитал в проводках и пару первичных документов на поступление товаров/услуг. Не стал заморачиваться.

По поводу банка (51 счет). Вижу, что он с минусами.

На вопрос: «ПОЧЕМУ? Это же грубейшая ошибка!». Ответ простой даже без дополнительных вопросов пользователю —

Предприниматель не парится на счет правильной выгрузки из банка в Мое Дело. И еще больше не парится на тему разнесения этого банка по бухгалтерским счетам.

Оно и понятно, это не его дело. Это дело бухгалтера, на котором так любят экономить.

В общем, после диагностики проблемы в диалоге выяснилось, что предприниматель любит Мое Дело потому что там удобно выставить Акт и как-то по своему разнести полученную оплату по счетам на оплату — так он контролирует текущую дебиторку.

Пришли к выводу, что пусть он выставляет первичку в Мое Дело только в части реализаций, а в конце месяца эти документы будут выгружаться в
родную среду бухгалтера — в 1С Бухгалтерию. В 1С будут формироваться бух и налоговые регистры, отчетность и отправляться xml файликом в Мое дело.

На мое предложение отправлять из 1С предприниматель ответил, что когда в Мое Дело всё горит «зелёненьким» в части сданных отчетов — ему так спокойнее. ОК, хозяин — барин.

Отчетность ИП

Проверка привязки аккаунтов

Для подключения возможности импорта документов из системы Sape выполните привязку аккаунта из интерфейса Паспорта. (passport.sape.ru/documents/iereport/1/).

После привязки аккаунта зайдите в систему «Моё дело» и убедитесь, что аккаунт успешно привязан: это можно проверить в разделе «Реквизиты / Интеграция», убедившись, что интеграция с Sape.Ru находится в разделе «Включенные интеграции».

Отчетность из системы Sape можно загружать в интерфейсе сервиса «Моё дело» в ручном и автоматическом режиме. Для управления выписками перейдите в раздел «Деньги».

Во время первой загрузки выписок для них будут созданы соответствующие контрагенты (например, контрагент ООО «Софтвэй» для агентского отчета о доходах вебмастера) и договоры, которые в дальнейшем будут использоваться в документообороте.

Автоматический режим загрузки документов

В начале каждого месяца будут доступны документы для загрузки за предыдущий месяц из системы Sape. Как только документы будут готовы, вы увидите уведомление «Вы получили новые выписки из Sape.Ru».

Нажмите на ссылку «Импортировать» для добавления документов в список.

Ручной режим загрузки документов

Вам может потребоваться загрузка документов за определенный период в прошлом. Для этого нажмите ссылку «Загрузить данные из Sape.Ru».

В открывшемся диалоговом окне выберите отчетный месяц и нажмите кнопку «ОК». Если выписки существуют за этот отчетный месяц, они будут загружены в список документов. В противном случае вы увидите соообщение об ошибке.

Тема 1С прямо нас не отпускает: тем более, когда на вопрос, что делать украинским бухгалтерам, компания нам не ответила, качая головой. Мы решили проанализировать, как живут другие бухгалтерские программы. И есть ли вообще сейчас рабочие альтернативы монополисту? Вдруг, и у нас захотят запретить…Будем готовы, как минимум.

Предлагаем в комментариях рассказать, какие проблемы у вас возникли при пользовании перечисленными программами и почему вы хотите перейти на другую (или уже перешли).

Недавно в группе Клерк.ру на сайте Facebook, Красном уголке бухгалтера, мы предложили нашим читателям принять участие в опросе относительно программы, в которой ведется учет.

📌 Реклама Отключить

С разгромным счетом победила 1С. Компания в представлении не нуждается. Там все масштано: 1С работает с пользователями через партнерскую сеть, которая включает более 10 000 постоянных партнеров в 600 городах из 25 стран. Как раз клиентам из другой страны пришлось недавно и понервничать. За последнюю неделю компания стала фигурантом сразу нескольких важных новостей. На Украине сначала коммерческим компаниям то якобы запрещали, то снова разрешали пользоваться 1С.

Думаю, читатели простят нас, если мы не будем подробно останавливаться на функциях и особенностях работы в 1С. Лучше подробно поговорим о других бухгалтерских программах, упомянутых в нашем опросе.

Турбо 9

Серебро нашего опроса у бухгалтерской программы Турбо 9, который разработал ДИЦ (Долгопрудненский исследовательский центр). Честно говоря, сайт программы выглядит пережитком времен модемного интернета. Но есть и онлайн-помощники, и форум, и горячая линия. 📌 Реклама Отключить

Тем не менее, разработчики предлагают полный спектр программных решений: и для автоматизации бухгалтерского, и налогового учета, и для управления персоналом, и для складского или отраслевого учета. Есть мини-программа Счетовод. Она разработана для ведения бухгалтерского учета «от проводки», без использования операционных документов.

Вот официальный прайс-лист от ДИЦ. Купить можно, позвонив по телефону, а также в интернет-магазине или у дилеров. Все как обычно.

Инфо-бухгалтер

На третьем месте в нашем опросе — программа Инфо-бухгалтер. В дизайне и удобстве поиска информации для потенциальных клиентов Инфо-бухгалтер недалеко ушел от Турбо-9. Впрочем, у Инфо-бухгалтер также есть и форум, и консультанты, которые по телефону или в электронном письме все объяснят. 📌 Реклама Отключить

Вообще, странно, почему даже у 1С сайт выглядит каким-то приветом из прошлого.

Но вернемся к Инфо-бухгалтеру. У программы обычный, то есть достаточный для большинства компаний фунционал. Представляя себя, разработчики делают упор на следующие особенности (цитируем):

  • Полное соответствие всем требованиям Минфина и ФНС России.
  • Всегда актуальная бухгалтерская и налоговая отчетность.
  • Все режимы налогообложения (ОРН, УСН, «Вмененка», «Патент» и др.).
  • Автоматизация всех участков бухгалтерского, налогового, кадрового, складского, управленческого учета.
  • Ведение учёта нескольких организаций и предпринимателей в одной программе.
  • Расчет заработной платы любой сложности и кадровый учет.
  • Учет основных средств и материалов.
  • Учет работ, услуг, торговый и складской учет.
  • Автоматизация рабочего места кассира-операциониста
  • Автоматическое формирование всех видов отчетности.
  • Выгрузка отчетности для предоставления в электронном виде.
  • Электронные счета-фактуры и электронные документы.
  • Регулярные бесплатные обновления.
  • Простота освоения и удобство в работе.

У программы есть и платные, и бесплатные версии. Вот прайс на все, что можно получить у Инфо-бухгалтера. Купить можно через их интернет-магазин или у региональных дилеров. 📌 Реклама Отключить

Для предприятий малого бизнеса и начинающих предпринимателей, предлагают бесплатную версию программы Инфо-Бухгалтер 10.2 с урезанным функционалом.

Контур-Эльба

Следующим в списке приоритетных бухгалтерских программ в нашем опросе значится Контур-Эльба. Возможности программы, в принципе, аналогичны всем рассмотренным выше.

Тут интерфейс и возможности для узнавания программы повеселее.

Прайс можно посмотреть . 30 дней обещают дать попользоваться бесплатно. Есть также приятные фишки для предпринимателей и тех, кто сдает нулевую отчетность.

Радует и то, что оплатить можно прямо на сайте электронными деньгами.

Мое дело

Сервис Мое дело позиционирует себя как интернет-бухгалтерия для малого бизнеса. Возможности такие, чтобы покрывать все, что нужно большинству небольших компаний и предпринимателей. Сервис выглядит современно. Цены такие. 📌 Реклама Отключить

Демонстрационную версию предлагают бесплатно.

БухСофт

БухСофт предлагает решения для разных систем налогообложения, малого бизнеса и отраслей. Разработчик особо подчеркивает: можно скачать программу на компьютер, а можно пользоваться онлайн без установки и специальных криптосредств.

Сайт выглядит современно. Можно посмотреть видео-подсказки и выбрать удобные варианты для себя.

Цены вот

Парус

Жив в памяти бухгалтеров и Парус. Правда, в нашем опросе его выбрал только один респондент. В комментариях пользователи отметили, что используют его сейчас государственные и муниципальные учреждения.

Мы поинтересовались: для бизнеса тоже есть предложения. Но опять же — только для крупняка: из машиностроения, химического сектора, энергетики, пищевой промышленности.

📌 Реклама Отключить

Кто еще?

Безусловно, мы рассказали далеко не обо всех бухгалтерских программах. Может, у вас в любимчиках сервисы или софт — пусть и не такие популярные, но дающие нужные именно вашему бизнесу опции? Рассказывайте.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *