Как в 1С переключить язык

  • автор:

В Windows Server при подключении к нему по rdp наблюдается такое явление, как две языковые панели у терминального пользователя. Одна с текстовым индикатором (RU|EN), вторая — с изображением клавиатуры. И при нажатии Alt-Shift или Ctrl-Shift (как у кого настроено) язык ввода не переключается.

Есть несколько способов решения данной проблемы:

Вариант 1.

Завершить сеанс на сервере, закрыть rdp-клиент на локальной машине. Заново подключится. Иногда помогает и если такой вариант устраивает, то можно больше ничего не делать.

Вариант 2.

Помогает в 90%.

Вариант 3.

На терминальном сервере от имени администратора внести изменения в реестр в ветке

HKLM\System\CurrentControlSet\Control\Keyboard Layout:

создать параметр IgnoreRemoteKeyboardLayout типа REG_DWORD(32bit) и установить значение 1.

Либо создать файл time.reg с таким содержанием
Windows Registry Editor Version 5.00

«IgnoreRemoteKeyboardLayout»=dword:00000001
И исполнить его.
Перезагрузка.
Помогает в 100% случаях.

Предупреждение. Неправильное изменение параметров системного реестра с помощью редактора реестра или любым иным способом может привести к серьезным неполадкам. Для их устранения может потребоваться переустановка операционной системы. Корпорация Майкрософт не гарантирует, что эти неполадки можно будет устранить. Ответственность за изменение реестра несет пользователь.

Интерфейс программного комплекса 1С может отображать информацию на разных языках. Это облегчает работу с платформой тем жителям страны, которые «русским» не владеют. Региональные установки программируются на этапе разработки комплекта, и пользователю остаётся лишь выбрать подходящий набор функций, чтобы данные в формах программы были переведены на нужный язык.

Случается и так, что приложение изначально поддерживает исключительно один язык интерфейса.

Для просмотра настроек нужно запустить 1С в режиме Конфигурации. Напротив записи «Основной язык» стоит значение.

Если нажать на кнопку с тремя точками, откроется меню выбора параметра и в нём только один вариант.

Таким образом, язык программы поменять в дальнейшем не получится.

Установка языка в 1С

Обычно платформа поддерживает только два значения: Английский и Русский. Это можно видеть в окне установки программы. Остальные доступные варианты отмечены крестиком.

Если в процессе настройки данной функции были внесены неправильные значения, то при активации программы некоторые пункты меню или данные в формах могут быть на английском, а другие – на русском.

Следует понять, как исправить эту ошибку, ведь пользоваться комплексом в таком виде весьма затруднительно.

Внесение коррективов в процесс установки

Чтобы запустить процедуру повторной инсталляции следует в Панели Управления Windows найти в разделе «Программы и компоненты» запись типа «1С: Предприятие» и выделить её кнопкой мыши. После этого нужно нажать на «Изменить».

Появится окно, предлагающее пользователю способы управления. Нужно выбрать вкладку ИЗМЕНИТЬ, активировав её правой клавишей указателя.

В главном окне выбора компонентов нам нужен раздел «Интерфейсы на различных языках». Он открывается щелчком мыши.

Потребуется выбрать один из отмеченных крестиком языков, и установить его в систему.

Далее приложение предложит пользователю выбрать язык интерфейса. Параметр «Системные установки» берёт значения из региональных настроек системы.

Нажимаем кнопку «Далее» и попадаем в окно завершения установки. После этого нужно запустить программу для контрольной проверки. Как видно на рисунке, все пункты переведены на русский язык.

Входим в любой выбранный документ и убеждаемся, что настройки были применены правильно.

Вспомогательный метод изменения языка в 1С

В окне запуска программы нажимаем кнопку «Изменить».

При редактировании настроек нужно изменить пункт «Дополнительные параметры запуска»: дописать код \Lru. Это пригодится, если комплекс работает на разных ПК и требуются индивидуальные установки для каждой из систем.

Коды для выбора других значений:

Изменение параметров запуска в файле конфигурации – conf.cfg

Для этого понадобится найти файл с названием conf.cfg, который находится в разделе с установленной программой (путь bin\conf).

Его можно изменить при помощи блокнота. Достаточно внести свои значения в параметр SystemLanguage.

Каждый из вышеуказанных кодов подходит. Значение system служит для того, чтобы интерфейса 1С менялся в соответствии с настройками Windows. Потребуется сохранить файл.

Установленное значение автоматически применится для всех компонентов, привязанных к платформе.

Установка языка интерфейса под определенного пользователя

В режиме конфигурационного запуска приложения следует найти всех потребителей системы посредством раздела «Администрирование-Пользователи».

В окне со списком, в правой его части, нужно выбрать определённую запись и в меню выбора языка установить значение.

Региональные настройки программы 1С

Во время работы с информационными базами (при активации новой или загрузке уже готовой ИБ) можно изменить региональные параметры.

При добавлении группы в разделе «Язык (Страна)» нужно выбрать из списка подходящее значение.

Если требуется подстроить параметры для каждой из баз данных, нужно в окне редактирования ИБ в разделе «Дополнительные параметры» внести запись \VL перед языковым кодом.

Изменение языка в веб-браузере

Когда комплекс 1С подключён через облачное хранилище, можно использовать региональные параметры веб-браузера для определения языка интерфейса. Для этого в адресной строке следует добавить запись /ru_RU.

Веб-браузер имеет право вносить свои коррективы, отчего данные иногда отображаются на нескольких языках. Отредактировать параметры можно посредством добавления нужного ключа запуска. Запустим приложение на английском языке (en_US).

Если система 1С поддерживает установку дополнительных языков, то вышеописанных методов будет вполне достаточно для редактирования настроек. Пользователь может в любой момент изменить язык программы.

Остались вопросы? Закажите бесплатную консультацию наших специалистов!

Для этого можно использовать функционал следующих внешних компонент:

Код 1C v 7.x Сервис=СоздатьОбъект(«Сервис»);
Сервис.РаскладкаКлавиатуры(«Russian»);
Код 1C v 7.x Если (ЗагрузитьВнешнююКомпоненту(«NetaTable.dll»)=1) Тогда
РовнаяТаблица=СоздатьОбъект(«AddIn.NTable»);
Иначе
Предупреждение(«Внешняя компонента AddIn.NetaTable НЕ подключена!!!»+РазделительСтрок+»Работа программы невозможна!!!»);
СтатусВозврата(0);
Возврат
КонецЕсли;
Процедура ПриНачалеВыбораЗначения(ИдентЭлемента,ФлагОтбора)
Если ИдентЭлемента = «Диагноз» Тогда
РовнаяТаблица.УстановитьРаскладку(67699721);
ИначеЕсли ИдентЭлемента = «ИсточникФинансирования» Тогда
РовнаяТаблица.УстановитьРаскладку(68748313);
КонецЕсли;
КонецПроцедуры
А можно и без внешних компонент:
Код 1C v 7.x //примеры Sserj
Процедура СменитьРаскладку(Реж)
//Можно и просто через wrapper.dll
//Wrapper = CreateObject(«DynamicWrapper»);
//Wrapper.Register(«USER32.DLL», «ActivateKeyboardLayout», «i=ll», «f=s», «r=l»);
//Wrapper.Register(«USER32.DLL», «LoadKeyboardLayout», «i=sl», «f=s», «r=l»);
//rus = Wrapper.LoadKeyboardLayout(«00000419», 0);
//eng = Wrapper.LoadKeyboardLayout(«00000409», 0);
//Если Реж = «RUS» Тогда
// Wrapper.ActivateKeyboardLayout(rus, 0);
//ИначеЕсли Реж = «EN» Тогда
// Wrapper.ActivateKeyboardLayout(eng , 0);
//КонецЕсли;
Если Не (Константа.ВключатьНамЛоокВТелефонах = Истина) Тогда
Возврат;
КонецЕсли;
wshShell=createObject(«wScript.shell»);
Если Реж = «RUS» Тогда
wshShell.SendKeys(«^(8)»,0);
ИначеЕсли Реж = «EN» Тогда
wshShell.SendKeys(«^(9)»,0);
КонецЕсли;
КонецПроцедуры // СменитьРаскладку(Реж)
//ЕЩЕ
//Обновляем хоткеи смены языков, для подмены в полях где нужна английская раскладка
текст = СоздатьОбъект(«текст»);
текст.ДобавитьСтроку(«Windows Registry Editor Version 5.00»);
текст.ДобавитьСтроку(«»);
текст.ДобавитьСтроку(«»);
текст.ДобавитьСтроку(«»»Virtual Key»»=hex:39,00,00,00»);
текст.ДобавитьСтроку(«»»Key Modifiers»»=hex:02,c0,00,00»);
текст.ДобавитьСтроку(«»»Target IME»»=hex:09,04,09,04»);
текст.ДобавитьСтроку(«»);
текст.ДобавитьСтроку(«»);
текст.ДобавитьСтроку(«»»Virtual Key»»=hex:38,00,00,00»);
текст.ДобавитьСтроку(«»»Key Modifiers»»=hex:02,c0,00,00»);
текст.ДобавитьСтроку(«»»Target IME»»=hex:19,04,19,04»);
ИмяФайла = КаталогИБ() + «LangHotKey.reg»;
Попытка
текст.Записать(ИмяФайла);

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *