1С кд выгрузитьпоправилу

  • автор:

Задача: в информационной базе (Бухгалтерия для Украины 2.0) ведется несколько предприятий. Принято решение разделить их и вести учет отдельно. Необходимо вынести одно предприятие в отдельную базу для продолжения работы в ней.

Для решения этой задачи есть несколько методов.

Метод 1. Разделение бухгалтерской базы по предприятиям с помощью РИБ

В примере рассматривается конфигурация «Бухгалтерия для Украины 2.0». Однако, полагаю, данное решение подойдет к большинству современных конфигураций на базе управляемого приложения.

Включаем синхронизацию данных

Для этого переходим в раздел «Администрирование» -> «Настройки синхронизации данных»:

Добавляем распределенную информационную базу (РИБ)

Добавляем синхронизацию данных «Распределенная информационная база с фильтром по организации»:

На следующем шаге указываем любой каталог:

Пропустив настройку FTP и e-mail переходим к указанию одной или нескольких организаций, которые мы будем переносить. Обязательно указываем префикс инфобазы.

Пропускаем страницу настроек и переходим к созданию образа РИБ:

Указываем каталог, в котором будет создана новая информационная база (в примере D:\tmp\Бух20-риб\):

После создания образа выйдет такое сообщение:

После чего в исходной базе необходимо удалить только что созданный элемент плана обмена и, при необходимости, отключить синхронизацию вообще.

Выполняем отключение главного узла в новой базе

Свежесозданная БД заблокирована средствами управления распределенной ИБ. Если мы планируем пользоваться новой базой как отдельной, а не распределенной, необходимо провести отключение от главного узла.

После первого старта новой базы запускается окно настройки синхронизации. Нажмем «Отмена» и «Да» и настройки синхронизации БД заполнятся по-умолчанию:

Для непосредственного отключения главного узла нам необходимо запустить конфигуратор с ключом «/ResetMasterNode». Проще всего это сделать с помощью параметра «Дополнительные параметры запуска» при добавлении информационной базы. Прописывам этот ключ и запускаем один раз конфигуратор (он отработает и закроется без каких-либо окон и сообщений), после чего для дальнейшей работы ключ запуска необходимо удалить.

Если далее просто запустить базу и согласиться на отключение от главного узла, мы получим ошибку (касается редакции Бухгалтерия для Украины 2.0.13.1 и, вероятно, некоторых других):

Платформа: 1С:Предприятие 8.3 (8.3.12.1790) Конфигурация: Бухгалтерия для Украины, редакция 2.0. (2.0.13.1) (http://1c.ua/v8/RegionalSolutions_UA_BUH.php) Copyright © Molenari OU, 2017-2018. All rights reserved Режим: Файловый (без сжатия) Приложение: Тонкий клиент Локализация: Информационная база: украинский (Украина), Сеанс: русский (Россия) Вариант интерфейса: Такси Ошибки: ——————————————————————————— 15.02.2019 15:53:52 У пользователя недостаточно прав на исполнение операции над базой данных. объект: ‘Справочник.ПараметрыСинхронизацииV77’; право: ‘Удаление’ Таблица: ‘RefSInf9672’, SDBL-команда: ‘DELETE’.

Чтобы избежать ее, необходимо добавить право «Удаление» справочника «ПараметрыСинхронизацииV77» для роли «Полные права». Для этого включаем возможность изменения в базе:

И добавляем нужно нам право:

Применив изменения, запускаем нашу информационную базу и подтверждаем отключение от главного узла:

Далее следуем рекомендациям сайта ИТС:

Константа «Настройка подчиненного узла РИБ завершена» — флаг должен быть снят

Константа «Это автономное рабочее место» — флаг должен быть снят.

Удаляем запись плана обмена, соответствующую главному узлу распределенной информационной базы и отключаем синхронизацию данных в панели администрирования (шаг 1).

Очистка от лишних данных

В записях регистов и справочников осталось множество «лишних» данных. Например, в справочнике «Контрагенты» есть «битые» ссылки на несуществующие договоры (остались от прошлой организации):

Для устранения необходимо запустить Тестирование и исправление информационной базы из под конфигуратора с указанием настройки «Очищать ссылки»:

Проверка

Для проверки корректности переноса сформируем ОСВ в базе-источнике и базе-приемнике и убедимся что они сходятся:

Плюсы и минусы разделения с помощью РИБ

К плюсам переноса с помощью РИБ можно отнести высокую скорость и относительную простоту процесса.

Минусы: элементы справочников переносятся не все присутсвующие в БД, а только те что используются в документах по организации. Для примера, можно привести справочник «Контрагенты»:

Метод 2. Разделения по организациям с помощью инструментов разработчика

Принцип разделения прост: берем копию базы, помечаем на удаление не нужные организации и удаляем все документы и элементы справочников, которые на них ссылаются. Для этого в панели «Инструменты разработчика» есть удобный инструмент «Удаление объектов с контролем ссылок».

Подготовка базы

Сначала сделаем копию нашей базы. Для работы будем использовать портативную версию инструментов разработчиков. Необходимо отключить «Защиту от опасных действий» в настройках пользователя в конфигураторе:

Также для корректной работы необходимо установить русский язык интерфейса пользователю, под которым будет производится «обрезка» базы.

Удаление «лишних» организаций

Открываем обработку инструменты разработчика портативный и запускаем обычное приложение (панель инструментов работает только в этом режиме):

Помечаем «лишние» организации на удаление:

В панели разработчика запускаем инструмент «Удаление объектов с контролем ссылок» и указываем что планируем работать со справочником «Организации»:

В верхней табличной части «Кандидаты» появятся 3 организации, помеченные на удаление. С помощью кнопки «Контроль» производится поиск ссылок на каждый из кандидатов. При желании, можно сразу удалить элементы, которые ссылаются на кандидата (если, конечно, на него нет других ссылок в БД).

После первого контроля нижняя табличная часть заполнится ссылками на объекты, которые ссылаются на кандидата. С помощью переключателя режима отбора «По кандидату», включается либо режим отображения в нижней ТЧ ссылок только на текущего кандидата, либо же на всех кандидатов.

В качестве первого шага, необходимо добавить все элементы, ссылающиеся на наших кандидатов, в список кандидатов на удаление. Для этого уберем отбор «По кандидату», выделим все элементы нижней таб. части (Ctrl+A), нажмем «В кандидаты». От пометки удаления лучше отказаться (при ошибке установки пометки удаления процесс будет прекращен).

Теперь можно запускать «Контроль» с удалением элементов, которые можно удалить. Дальнейшие проблемы удаления связанных элементов рассматриваем в ручном режиме. Всегда можно посмотреть кто ссылается на элемент, установив отбор «По кандидату».

Банковские счета

Удалить банковский счет по организации «Добро» мешают 4 ссылки на приходные кассовые ордера:

Каждый из них можно открыть и просмотреть с помощью двойного клика на колонку «Объект»:

Как ни странно, но документ организации «Пилот» визуально не содержит ссылок на р/сч организации «Добро». Для поиска ссылки воспользуемся еще одним удобным инструментом «Редактор объекта БД», который можно вызвать с помощью кнопки «Редактировать». По клику открывается окно редактора объекта БД и в нём подсвечивается найденная ссылка.

Удивительно, но в документе в реквизите «Счет организации» действительно пристутствует ссылка на р/сч организации «Добро». Такое, зачастую, случается когда пользователи копируют документ, меняют в нем вид операции и организацию. Поскольку документов у нас не много, откроем каждый из них и вручную очистим реквизит «Счет организации». Теперь после нажатия кнопки «Контроль» эти документы пропадут из списка препятствующих удалению.

Подразделения организаций

На помеченные к удалению подразделения организаций присутствует множество ссылок справочника «Способы отражения расходов по амортизации», на которые, в свою очередь, ссылаются элементы справочника «Назначения использования». В нашей задаче все препятствующие удалению элементы справочника «Назначения использования» необходимо добавить в кандидаты к удалению. Для этого выделим любой элемент из нижней таб. части в колонке «Метаданные объекта» и применим команду «Отбор по значению в текущей колонке», после чего кнопку «В кандидаты».

Справочник «Файлы»

У организации «Добро» в БД присутствуют 2 хранимых файла. Эти файлы присутствуют в кандидатах на удаление, но на них ссылаются элементы справочника «Версии файлов». Попробуем открыть элемент справочника и пометить его на удаление вручную (это также можно сделать через добавление в кандидаты с установкой пометки удаления):

В событии «Перед записью» срабатывает триггер, который запрещает установку пометки удаления. В нашем случае, мы уверены, что файлы сторонней организации нам не нужны, поэтому элементы справочника можно удалить «грубо», т. е. без контроля ссылочной целостности. Для этого есть специальная команда в инструменте «Редактор объекта БД»:

Контрагенты

У контрагентов есть реквизит «Основной договор», который ссылается на договор с одной из удаляемых организаций. Следовательно, необходимо очистить ссылку на основной договор у таких контрагентов. Для этого наиболее удобным будет инструмент «Консоль запросов». В нем мы можем задать запрос к БД и на вкладке «Обработка строки результата» указать программный код, который будет выполнен для каждой полученной строки результата запроса.

В качестве запроса для нас будет оптимально найти контрагентов, у которых реквизит «Организация» основного договора помечена на удаление.

Для каждого найденного контрагента будет применен следующий код:

Объект = СтрокаРезультата.Ссылка.ПолучитьОбъект(); // Обработка объекта Объект.ОсновнойДоговорКонтрагента = Справочники.ДоговорыКонтрагентов.ПустаяСсылка(); //Объект.ОбменДанными.Загрузка = Истина; Объект.Записать();

Документ «Установка цен номенклатуры»

В списке документов, препятсвующих удалению, присутствует «Установка цен номенклатуры». С помощью редактора объекта БД найден ссылку на организацию:

Ссылка на организацию «ПП Петренко» присутствует в последовательности «Документы организаций». Инструмент «Редактор объекта БД» позволяет редактировать не только реквизиты объекта, но и движения документа. Удалим движение и запишем объект помощью кнопки «Записать движения».

Справочник «Зарплатные проекты»

На зарплатные проекты ссылаются элементы регистра сведений «Лицевые счета сотрудников по зарплатным проектам»:

Проще всего в нашем случае будет зайти в форму списка этого регистра сведений, выделить все записи и удалить их:

Другие ссылки на регистры сведений

Другие ссылки на регистры сведений лучше всего будет добавить в список неблокирующих, чтобы они не препятствовали удалению. В дальнейшем, при тестировании и исправлении БД, эти ссылки будут очищены.

Тестирование и исправление БД

После нажатия кнопки «Контроль» все помеченные организации будут удалены. Пора провести тестирование и исправление информационной базы с пометкой «Очищать ссылки»:

Плюсы и минусы разделения с помощью инструментов разработчика

Плюсы:

  1. Полный контроль над процессом;
  2. Справочники номенклатура, контрагенты и пр. полностью перенесены.

Минусы:

  1. Полуручная работа;
  2. Требует программирования.

Описание функции ВыгрузитьПоПравилу().

Функция ВыгрузитьПоПравилу() используется для выгрузки объекта в xml-узел и возвращает узел ссылки на этот объект.

В процессе выгрузки эта функция вызывается из:

ПВД, когда объект из выборки получен и необходимо произвести его конвертацию.

ПКО, когда необходимо выгрузить связанную с выгружаемым объектом информацию.

ПКС, когда свойство имеет ссылочный тип и необходимо выгрузить по ссылке из этого свойства объект.

Из функции ВыгрузитьПоПравилу() могут быть вызваны другие функции, выгружающие субконто, свойства и т.д. этого объекта, а из этих функций – рекурсивно может быть вызвана функция ВыгрузитьПоПравилу(). После того, как объект со всеми необходимыми свойствами выгружен, управление возвращается в то место кода, откуда функция была вызвана. Таким образом, вызов этой функции из обработчиков событий какого-либо правила (ПВД, ПКО, ПКС), не изменяет процесса выгрузки объекта по этому правилу.

Функция ВыгрузитьПоПравилу() имеет ряд параметров
ВыгрузитьПоПравилу(Источник,
Приемник,
ВходящиеДанные,
ИсходящиеДанные,
ИмяПКО,
УзелСсылки,
ТолькоПолучитьУзелСсылки,
ПКО,
ЭтоПравилоСГлобальнойВыгрузкойОбъектов,
ВыборкаДляВыгрузкиДанных)

Все эти параметры в функции имеют значения по умолчанию, и, как правило, передавать имеет смысл только параметр ИмяПКО, а также параметры Источник и/или ВходящиеДанные – в зависимости от того, как настроено ПКО.

ИмяПКО – строка, название ПКО, в которое передаем управление.
Источник – ссылка на элемент объекта-источника, который передаем для конвертации.
ВходящиеДанные – структура. Элементы в ней должны быть названы аналогично ПКС, у которых стоит флаг «Получить из входящих данных». Если таких ПКС нет, передавать этот параметр не нужно. Если в ПКО у всех ПКС стоит флаг «Получить из входящих данных», то, наоборот, необходимо передать структуру ВходящиеДанные, а Источник тогда передавать не нужно.

Выгрузка произвольной выборки данных через стандартную выборку с регистрацией объекта источника.

Необходимость в такой задаче может возникнуть, когда объект «источника» и объект «приемника» имеют различную смысловую или функциональную структуру.

Например, документ «источника» позволяет вводить информацию по нескольким подразделениям предприятия, документ «приемника» позволяет вводить информацию только об одном подразделении предприятия.

Данная задача отлично решается при помощи произвольного алгоритма выборки в ПВД, но данное решение имеет два недостатка:

  1. Мы лишаемся механизма регистрации изменений;
  2. Алгоритм произвольной выборки отказывается работать в БСП.

БСП — библиотека стандартных подсистем. В частности, имеет своем составе подсистему «Обмен данными», данная подсистема реализует механизмы автоматической синхронизации данных между конфигурациями, по правилам написанным в Конвертации данных.

  1. Создаем ПВД со Стандартным алгоритмом выборки;
  2. Указываем объект выборки;
  3. Пишем обработчик «Перед выгрузкой»(хочу подчеркнуть, что нужно использовать именно этот обработчик). Например, следующего содержания:

//Начинаем отбор данных для выгрузки Запрос = Новый Запрос; Запрос.Текст = «ВЫБРАТЬ РАЗЛИЧНЫЕ | ПриемНаРаботуВОрганизациюРаботникиОрганизации.Сотрудник, | ПриемНаРаботуВОрганизациюРаботникиОрганизации.ПодразделениеОрганизации КАК Подразделение, | ПриемНаРаботуВОрганизациюРаботникиОрганизации.Должность, | ПриемНаРаботуВОрганизациюРаботникиОрганизации.ЗанимаемыхСтавок КАК Ставка, | ПриемНаРаботуВОрганизациюРаботникиОрганизации.ДатаПриема, | ПриемНаРаботуВОрганизациюРаботникиОрганизации.Сотрудник.ВидЗанятости КАК ВидЗанятости, | ПриемНаРаботуВОрганизациюРаботникиОрганизации.Ссылка.Дата, | ПриемНаРаботуВОрганизациюРаботникиОрганизации.Ссылка.Номер, | ПриемНаРаботуВОрганизациюРаботникиОрганизации.Ссылка.Проведен, | ВЫБОР | КОГДА ПриемНаРаботуВОрганизациюОсновныеНачисления.ВидРасчета = ЗНАЧЕНИЕ(ПланВидовРасчета.ОсновныеНачисленияОрганизаций.ОкладПоЧасам) | ТОГДА ИСТИНА | ИНАЧЕ ЛОЖЬ | КОНЕЦ КАК СдельнаяОплатаТруда, | ПриемНаРаботуВОрганизациюОсновныеНачисления.ВидРасчета КАК ВидРасчета |ИЗ | Документ.ПриемНаРаботуВОрганизацию.РаботникиОрганизации КАК ПриемНаРаботуВОрганизациюРаботникиОрганизации | ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.ПриемНаРаботуВОрганизацию.ОсновныеНачисления КАК ПриемНаРаботуВОрганизациюОсновныеНачисления | ПО ПриемНаРаботуВОрганизациюРаботникиОрганизации.Ссылка = ПриемНаРаботуВОрганизациюОсновныеНачисления.Ссылка | И ПриемНаРаботуВОрганизациюРаботникиОрганизации.Сотрудник = ПриемНаРаботуВОрганизациюОсновныеНачисления.Сотрудник |ГДЕ | ВЫБОР | КОГДА &ИспользоватьОтборПоПодразделениям ТОГДА | ПриемНаРаботуВОрганизациюРаботникиОрганизации.ПодразделениеОрганизации В ИЕРАРХИИ (&Подразделения) | ИНАЧЕ | ИСТИНА | КОНЕЦ | И ВЫБОР | КОГДА &ИспользоватьОтборПоВидамРасчета ТОГДА | ПриемНаРаботуВОрганизациюОсновныеНачисления.ВидРасчета В ИЕРАРХИИ (&ВидРасчета) | ИНАЧЕ | ИСТИНА | КОНЕЦ | И ПриемНаРаботуВОрганизациюРаботникиОрганизации.Ссылка = &Ссылка»; Выполнить(Алгоритмы.ЗаполнитьПараметрыОтбораПоВидамРасчета); Запрос.УстановитьПараметр(«Ссылка», Объект.Ссылка); Выполнить(Алгоритмы.ЗаполнитьПараметрыОтбораПоПодразделениям); ВыбранныеДанные = Неопределено; ПустаяТабличнаяЧасть = Неопределено; Выполнить(Алгоритмы.ПолучитьСтруктуруВыгрузкиКадровыхДокументов); РезультатЗапроса = Запрос.Выполнить().Выгрузить(); Сотрудники = ПустаяТабличнаяЧасть.Скопировать(); СтрокаДокумента = Неопределено; Для Каждого СтрокаРезультата Из РезультатЗапроса Цикл ДанныеИзВнешнихСистем = «Выгружено из ЗиКБУ, документ «»Прием на работу в организацию»» №» + СтрокаРезультата.Номер + » от » + Формат(СтрокаРезультата.Дата, «ДФ=dd.MM.yyyy») + «, » + СтрокаРезультата.Подразделение.Наименование; СтрокаДокумента = ВыбранныеДанные.Найти(ДанныеИзВнешнихСистем); Если СтрокаДокумента = Неопределено Тогда СтрокаДокумента = ВыбранныеДанные.Добавить(); СтрокаДокумента.Дата = СтрокаРезультата.ДатаПриема; СтрокаДокумента.Кафедра = СтрокаРезультата.Подразделение; СтрокаДокумента.Проведен = СтрокаРезультата.Проведен; СтрокаДокумента.ДокументСАктивнымиДолжностями = Истина; СтрокаДокумента.ДанныеИзВнешнихСистем = ДанныеИзВнешнихСистем; СтрокаДокумента.АктивныеДолжности = ПустаяТабличнаяЧасть.Скопировать(); СтрокаДокумента.НеактивныеДолжности = ПустаяТабличнаяЧасть.Скопировать(); КонецЕсли; СтрокаРаботников = СтрокаДокумента.АктивныеДолжности.Добавить(); СтрокаРаботников.Должность = СтрокаРезультата.Должность; СтрокаРаботников.Сотрудник = СтрокаРезультата.Сотрудник.Физлицо; СтрокаРаботников.Ставка = СтрокаРезультата.Ставка * 100; СтрокаРаботников.ВидНачисления = СтрокаРезультата.ВидРасчета; СтрокаРаботников.ВидЗанятости = СтрокаРезультата.ВидЗанятости; КонецЦикла; //Переводим отобранные данные из Таблицы значений в Массив структур для дальнейшей передачи в ПКО ДокументыЗакреплениеЗаКафедрой = Неопределено; Выполнить(Алгоритмы.ПереводТаблицыЗначенийВМассивЗакреплениеЗаКафедрой); //Обходим отобранные данные и выгружаем с помощью функции ВыгрузитьПоПравилу Для каждого Документ Из ДокументыЗакреплениеЗаКафедрой Цикл ВыгрузитьПоПравилу(,,Документ,,»ЗакреплениеЗаКафедройИзВходящихДанных»); КонецЦикла; //Отменяем стандартную выгрузку объекта Отказ = Истина;

Большую часть этого обработчика, как вы можете видеть, занимает отбор данных необходимых для выгрузки. Тут и множество фильтров: по подразделениям, по видам расчетов и механизм разбиения одного документа «источника» на несколько документов «приемника». Если коротко, то в данном примере табличная часть одного документа «источника» разносится по табличным частям нескольких документов «приемника», а значением разбиения данных является значение Подразделения.
Для удобства работы при отборе данных мы использовали Таблицу значений, наш алгоритм подразумевает ПКО с получением данных из «входящих данных», которые будут переданы в функцию ВыгрузитьПоПравилу, поэтому в соответсвующем алгоритме мы производим перевод Таблицы значений в Массив структур.
На следующем шаге мы обходим отобранные данные и вот уже в этом месте мы используем нашу функцию ВыгрузитьПоПравилу. Параметр Документ, здесь является структурой, которую мы передаем как входящие данные, а второй передаваемый нами параметр, это название ПКО, которому мы передаем наши данные.
В самом конце мы отменяем выполнение стандартной выгрузки, так как все необходимые данные связанные с объектом выборки мы уже выгрузили.
Тем самым мы сохраняем функциональность регистрации изменений — документ изменился, зарегистрировался для выгрузки, данные выгрузили. И в то же время делаем произвольный отбор необходимых нам данных.

В ПКО в этом случае для свойств необходимо указать, что они получаются из «Входящих данных».

Выгрузка Регистр сведений -> Регистр сведений с зависимостью от переноса другого объекта.

Типичным примером такой задачи является перенос контактной информации физического лица. Простейший способ решения задачи — это перенос всех «Физических лиц» и всего регистра сведений «Контактная информация» физических лиц. Что делать если нам необходимо переносить не всех физических лиц? Например, только тех физических лиц, которые упоминаются в каком-либо переносимом нами документе. В таком случае, как известно, ПКС документа вызывает ПКО справочника «Физические лица» и тем самым обеспечивается перенос физических лиц упоминаемых в документе.

В переносе «Контактной информации» физических лиц в данной ситуации может помочь функция ВыгрузитьРегистр, очень похожая на функцию ВыгрузитьПоПравилу.

Хочу отметить, что потребность в использовании функции ВыгрузитьРегистр у меня появилась, когда я начал адаптировать правила под БСП уже отлаженные на обработке Универсальный обмен XML. Регистры через обработку спокойно выгружались с использованием функции ВыгрузитьПоПравилу, но БСП ни как не хотело правильно понимать такую выгрузку, в результате чего пришлось переписывать код через ВыгрузитьРегистр.

В обработчике»После выгрузки в файл» ПКО «Физические лица», пишем код следующего вида:

////////////////////////////////////////////////////// //Выгрузим контактную информацию типа Адрес Запрос = Новый Запрос; Запрос.Текст = «ВЫБРАТЬ | КонтактнаяИнформация.Представление, | КонтактнаяИнформация.Вид, | КонтактнаяИнформация.Тип, | КонтактнаяИнформация.Объект |ИЗ | РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация |ГДЕ | КонтактнаяИнформация.Тип = ЗНАЧЕНИЕ(Перечисление.ТипыКонтактнойИнформации.Адрес) | И КонтактнаяИнформация.Вид В (ЗНАЧЕНИЕ(Справочник.ВидыКонтактнойИнформации.ЮрАдресФизЛица), ЗНАЧЕНИЕ(Справочник.ВидыКонтактнойИнформации.ФактАдресФизЛица)) | И КонтактнаяИнформация.Объект = &Объект»; Запрос.УстановитьПараметр(«Объект», Источник); Выборка = Запрос.Выполнить ().Выбрать (); Пока Выборка.Следующий () Цикл Отбор = Новый ТаблицаЗначений; Отбор.Колонки.Добавить («Имя»); Отбор.Колонки.Добавить («Значение»); Отбор.Колонки.Добавить («Использование»); СтрокаОтбора = Отбор.Добавить (); СтрокаОтбора.Имя = «Объект»; СтрокаОтбора.Значение = Выборка.Объект; СтрокаОтбора.Использование = Истина; Строки = Новый ТаблицаЗначений; Строки.Колонки.Добавить(«Представление»); Строки.Колонки.Добавить(«Вид»); Строки.Колонки.Добавить(«Тип»); Строки.Колонки.Добавить(«Объект»); Строка = Строки.Добавить(); Строка.Представление = Выборка.Представление; Строка.Вид = Выборка.Вид; Строка.Тип = Выборка.Тип; Строка.Объект = Выборка.Объект; НаборЗаписей = Новый Структура(«Отбор, Строки»); НаборЗаписей.Отбор = Отбор; НаборЗаписей.Строки = Строки; ВыгрузитьРегистр(НаборЗаписей,,,,»КонтактнаяИнформация»); КонецЦикла;

Как видно, в коде отбираются все записи регистра сведений, относящиеся к текущему выгружаемому Физическому лицу, а полученная выборка обходится в цикле.

Для того, чтобы выгрузить записи регистра сведений через функцию ВыгрузитьРегистр, необходимо подготовить структуру НаборЗаписей, которая имеет два поля: Отбор и Строки.

ПКО «КонтактнаяИнформация» имеет следующий вид:

Выгрузка Табличная часть -> Регистр сведений.

По своему решению задача аналогична предыдущей. С той лишь разницей, что информацию для регистра сведений «приемника» брать придется из других объектов «источника», а точнее табличной части того объекта, который на данный момент выгружается. Если бы на стороне «приемника» была так же табличная часть, то задача легко решалась бы в виде ПГКС. Поэтому снова воспользуемся функцией ВыгрузитьРегистр.

Рассмотрим пример переноса информации по ученым степеням Физического лица. Опять создаем код в обработчике «После выгрузки в файл» ПКО «Физические лица». Так как задача аналогичная предыдущей привожу только, код отбора и выгрузки данных из обработчика:

/////////////////////////////////////////////////////// //Выгрузим информацию по ученым степеням Запрос = Новый Запрос; Запрос.Текст = «ВЫБРАТЬ | ФизическиеЛицаУченыеСтепени.Ссылка, | ФизическиеЛицаУченыеСтепени.УченаяСтепень, | ФизическиеЛицаУченыеСтепени.ОтрасльНауки, | ФизическиеЛицаУченыеСтепени.ДипломСерияНомер, | ФизическиеЛицаУченыеСтепени.ДатаПрисужденияУченойСтепени |ИЗ | Справочник.ФизическиеЛица.УченыеСтепени КАК ФизическиеЛицаУченыеСтепени |ГДЕ | ФизическиеЛицаУченыеСтепени.Ссылка = &ФизЛицо»; Запрос.УстановитьПараметр(«ФизЛицо», Источник); Выборка = Запрос.Выполнить().Выбрать(); Пока Выборка.Следующий() Цикл Отбор = Новый ТаблицаЗначений; Отбор.Колонки.Добавить («Имя»); Отбор.Колонки.Добавить («Значение»); Отбор.Колонки.Добавить («Использование»); СтрокаОтбора = Отбор.Добавить (); СтрокаОтбора.Имя = «ФизическоеЛицо»; СтрокаОтбора.Значение = Выборка.Ссылка; СтрокаОтбора.Использование = Истина; Строки = Новый ТаблицаЗначений; Строки.Колонки.Добавить(«Ссылка»); Строки.Колонки.Добавить(«ФизическоеЛицо»); Строки.Колонки.Добавить(«УченаяСтепень»); Строки.Колонки.Добавить(«Специальность»); Строки.Колонки.Добавить(«НомерДиплома»); Строки.Колонки.Добавить(«Период»); Строка = Строки.Добавить(); Строка.ФизическоеЛицо = Выборка.Ссылка; Строка.УченаяСтепень = Выборка.УченаяСтепень; Строка.Специальность = Выборка.ОтрасльНауки; Строка.НомерДиплома = Выборка.ДипломСерияНомер; Строка.Период = Выборка.ДатаПрисужденияУченойСтепени; НаборЗаписей = Новый Структура(«Отбор, Строки»); НаборЗаписей.Отбор = Отбор; НаборЗаписей.Строки = Строки; ВыгрузитьРегистр(НаборЗаписей,,,Истина,»УченыеСтепениФизическихЛиц»); КонецЦикла;

Выгрузка Табличная часть -> Документ.

Предположим, в «источнике» информация для переноса хранится в менее детализированном виде, чем в приемнике, но достаточном для переноса. Например, мной решалась задача по переносу информации об образовании физических лиц из ЗиКБУ в Университет. Понятно, что на стороне кадровой программы нужна минимальная информация об образовании физических лиц, главное что сотрудник обладает необходимой квалификацией и хватит. А вот на стороне университета, информация об образовании, а точнее о дипломах хранится куда более подробно, в связи со спецификой учереждения.

И опять задача решается, при помощи все той же функции ВыгрузитьПоПравилу.

Вот пример выгрузки Дипломов физических лиц. Все тот же обработчик «После выгрузки в файл» ПКО «Физические лица», пишем следующий код:

/////////////////////////////////////////////////////// //Выгрузим образование Физического лица Запрос = Новый Запрос; Запрос.Текст = «ВЫБРАТЬ | ФизическиеЛицаОбразование.Ссылка КАК Студент, | ФизическиеЛицаОбразование.ВидОбразования, | ФизическиеЛицаОбразование.УчебноеЗаведение, | ФизическиеЛицаОбразование.Специальность.Наименование КАК Специальность, | ФизическиеЛицаОбразование.Диплом, | ФизическиеЛицаОбразование.ГодОкончания, | ФизическиеЛицаОбразование.Квалификация |ИЗ | Справочник.ФизическиеЛица.Образование КАК ФизическиеЛицаОбразование |ГДЕ | ФизическиеЛицаОбразование.Ссылка = &ФизЛицо»; Запрос.УстановитьПараметр(«ФизЛицо», Источник); РезультатЗапроса = Запрос.Выполнить(); ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать(); Пока ВыборкаДетальныеЗаписи.Следующий() Цикл ВходящиеДанные = Новый Структура; ВходящиеДанные.Вставить(«Студент», ВыборкаДетальныеЗаписи.Студент); ВходящиеДанные.Вставить(«ВидОбразования», ВыборкаДетальныеЗаписи.ВидОбразования); ВходящиеДанные.Вставить(«ОбразовательноеУчреждениеПриОкончании», ВыборкаДетальныеЗаписи.УчебноеЗаведение); ВходящиеДанные.Вставить(«Специальность», ВыборкаДетальныеЗаписи.Специальность); СерияНомерДиплома = ВыборкаДетальныеЗаписи.Диплом; СерияДиплома = «»; НомерДиплома = «»; Выполнить(Алгоритмы.ПолучитьСериюИНомер); ВходящиеДанные.Вставить(«СерияДиплома», СерияДиплома); ВходящиеДанные.Вставить(«НомерДиплома», НомерДиплома); Если НЕ ВыборкаДетальныеЗаписи.ГодОкончания = 0 Тогда ВходящиеДанные.Вставить(«ГодЗавершения», Дата(ВыборкаДетальныеЗаписи.ГодОкончания, 1, 1)); ВходящиеДанные.Вставить(«ДатаВыдачи», Дата(ВыборкаДетальныеЗаписи.ГодОкончания, 1, 1)); Иначе ВходящиеДанные.Вставить(«ГодЗавершения», Дата(«00010101»)); ВходящиеДанные.Вставить(«ДатаВыдачи», Дата(«00010101»)); КонецЕсли; ВходящиеДанные.Вставить(«Квалификация», ВыборкаДетальныеЗаписи.Квалификация); ВыгрузитьПоПравилу(,,ВходящиеДанные,,»ДипломИзВходящихДанных»); КонецЦикла;

Тут мы отбираем данные из табличной части и формируем входящие данные для документа на стороне «приемника», после чего при помощи функции ВыгрузитьПоПравилу, передаем входящие данные ПКО ДипломИзВходящихДанных, которое имеет следующий вид:

В общем, как вы понимаете, можно приводить еще много вариаций перегрузок: справочники, документы, регистры. Главное, надо понимать, что не стоит фанатично бросаться на функции ВыгрузитьПоПравилу и ВыгрузитьРегистр.

Замечания по перегрузке.

1. У меня возникли сложности при использовании правил в БСП, в части выгрузки объектов по ссылкам, проблема решилась принудительной установкой параметра ВыгрузитьОбъект в значение Истина, для каждого ПКС ссылочного типа:

2. Надо помнить, что при выгрузке через указанные функции, зачастую отсутствует УникальныйИдентификатор объекта, например, когда объект для выгрузки собирается по частям в виде структуры ВходящихДанных, поэтому поиск по уникальному идентификатору придется отключить.

Подводим итоги. Когда использовать эти функции?

  1. Вам необходимо перегрузить объекты с сильно различной структурой или на стороне «источника» необходимо собирать объекты для выгрузки из разных объектов.
  2. Вам необходимо перегружать объекты с привязкой к выгрузке других объектов.

А что если оптимизировать выше написанное?

Пишу дополнение к статье, после оставленного пользователем TarasovAV комментария. Данный пользователь заметил, что можно оптимизировать выгрузку связанной информации, путем накопления списка тех объектов, информацию о которых надо будет отдельно выгружать, а потом через один запрос отобрать сразу всю информацию.

Описываю алгоритм предложенный вышеуказанным пользователем:

1. В правиле конвертации «После загрузки правил обмена», создается параметр типа ТаблицаЗначений, в который будет накапливаться список объектов, для которых в последующем будет выгружаться информация:

Параметры.Вставить(«СписокФизическихЛиц», Новый ТаблицаЗначений()); Параметры.СписокФизическихЛиц.Колонки.Добавить(«ФизическоеЛицо»);

2. В в обработчике «После выгрузки» ПКО «Физические лица» (именно для них в примерах мы выгружаем контактные данные, образование и т.п.), мы пополняем нашу таблицу значений новым физическим лицом, проверяя перед этим, а не добавлено ли уже это физическое лицо в таблицу:

НайденнаяСтрока = Параметры.СписокФизическихЛиц.Найти(Источник); Если НайденнаяСтрока = Неопределено Тогда НоваяСтрока = Параметры.СписокФизическихЛиц.Добавить(); НоваяСтрока.ФизическоеЛицо = Источник; КонецЕсли;

3. И финальным действием, будет непосредственная выгрузка информации, только уже с отбором по все физическим лицам сразу. Для этого все обработчики, что были приведены выше начиная, необходимо перенести в правило конвертации «После выгрузки данных», запросы же необходимо изменить, чтобы в них проверялось не равенство одному элементу, а вхождение значения реквизита в массив элементов:

Обратите внимание, как изменилась установка параметра запроса и проверка условия в запросе:

//… «| И КонтактнаяИнформация.Объект В &СписокФизЛицо»; Запрос.УстановитьПараметр(«СписокФизЛицо», Параметры.СписокФизическихЛиц.ВыгрузитьКолонку(«ФизическоеЛицо»)); //…

Привожу полный код, исправленных ранее приведенных примеров:

////////////////////////////////////////////////////// //Выгрузим контактную информацию типа Адрес Запрос = Новый Запрос; Запрос.Текст = «ВЫБРАТЬ | КонтактнаяИнформация.Представление, | КонтактнаяИнформация.Вид, | КонтактнаяИнформация.Тип, | КонтактнаяИнформация.Объект |ИЗ | РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация |ГДЕ | КонтактнаяИнформация.Тип = ЗНАЧЕНИЕ(Перечисление.ТипыКонтактнойИнформации.Адрес) | И КонтактнаяИнформация.Вид В (ЗНАЧЕНИЕ(Справочник.ВидыКонтактнойИнформации.ЮрАдресФизЛица), ЗНАЧЕНИЕ(Справочник.ВидыКонтактнойИнформации.ФактАдресФизЛица)) | И КонтактнаяИнформация.Объект В &СписокФизЛицо»; Запрос.УстановитьПараметр(«СписокФизЛицо», Параметры.СписокФизическихЛиц.ВыгрузитьКолонку(«ФизическоеЛицо»)); Выборка = Запрос.Выполнить ().Выбрать (); Пока Выборка.Следующий () Цикл Отбор = Новый ТаблицаЗначений; Отбор.Колонки.Добавить («Имя»); Отбор.Колонки.Добавить («Значение»); Отбор.Колонки.Добавить («Использование»); СтрокаОтбора = Отбор.Добавить (); СтрокаОтбора.Имя = «Объект»; СтрокаОтбора.Значение = Выборка.Объект; СтрокаОтбора.Использование = Истина; Строки = Новый ТаблицаЗначений; Строки.Колонки.Добавить(«Представление»); Строки.Колонки.Добавить(«Вид»); Строки.Колонки.Добавить(«Тип»); Строки.Колонки.Добавить(«Объект»); Строка = Строки.Добавить(); Строка.Представление = Выборка.Представление; Строка.Вид = Выборка.Вид; Строка.Тип = Выборка.Тип; Строка.Объект = Выборка.Объект; НаборЗаписей = Новый Структура(«Отбор, Строки»); НаборЗаписей.Отбор = Отбор; НаборЗаписей.Строки = Строки; ВыгрузитьРегистр(НаборЗаписей,,,,»КонтактнаяИнформация»); КонецЦикла; /////////////////////////////////////////////////////// //Выгрузим образование Физического лица Запрос = Новый Запрос; Запрос.Текст = «ВЫБРАТЬ | ФизическиеЛицаОбразование.Ссылка КАК Студент, | ФизическиеЛицаОбразование.ВидОбразования, | ФизическиеЛицаОбразование.УчебноеЗаведение, | ФизическиеЛицаОбразование.Специальность.Наименование КАК Специальность, | ФизическиеЛицаОбразование.Диплом, | ФизическиеЛицаОбразование.ГодОкончания, | ФизическиеЛицаОбразование.Квалификация |ИЗ | Справочник.ФизическиеЛица.Образование КАК ФизическиеЛицаОбразование |ГДЕ | ФизическиеЛицаОбразование.Ссылка В &СписокФизЛицо»; Запрос.УстановитьПараметр(«СписокФизЛицо», Параметры.СписокФизическихЛиц.ВыгрузитьКолонку(«ФизическоеЛицо»)); РезультатЗапроса = Запрос.Выполнить(); ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать(); Пока ВыборкаДетальныеЗаписи.Следующий() Цикл ВходящиеДанные = Новый Структура; ВходящиеДанные.Вставить(«Студент», ВыборкаДетальныеЗаписи.Студент); ВходящиеДанные.Вставить(«ВидОбразования», ВыборкаДетальныеЗаписи.ВидОбразования); ВходящиеДанные.Вставить(«ОбразовательноеУчреждениеПриОкончании», ВыборкаДетальныеЗаписи.УчебноеЗаведение); ВходящиеДанные.Вставить(«Специальность», ВыборкаДетальныеЗаписи.Специальность); СерияНомерДиплома = ВыборкаДетальныеЗаписи.Диплом; СерияДиплома = «»; НомерДиплома = «»; Выполнить(Алгоритмы.ПолучитьСериюИНомер); ВходящиеДанные.Вставить(«СерияДиплома», СерияДиплома); ВходящиеДанные.Вставить(«НомерДиплома», НомерДиплома); Если НЕ ВыборкаДетальныеЗаписи.ГодОкончания = 0 Тогда ВходящиеДанные.Вставить(«ГодЗавершения», Дата(ВыборкаДетальныеЗаписи.ГодОкончания, 1, 1)); ВходящиеДанные.Вставить(«ДатаВыдачи», Дата(ВыборкаДетальныеЗаписи.ГодОкончания, 1, 1)); Иначе ВходящиеДанные.Вставить(«ГодЗавершения», Дата(«00010101»)); ВходящиеДанные.Вставить(«ДатаВыдачи», Дата(«00010101»)); КонецЕсли; ВходящиеДанные.Вставить(«Квалификация», ВыборкаДетальныеЗаписи.Квалификация); ВыгрузитьПоПравилу(,,ВходящиеДанные,,»ДипломИзВходящихДанных»); КонецЦикла; /////////////////////////////////////////////////////// //Выгрузим информацию по ученым степеням Запрос = Новый Запрос; Запрос.Текст = «ВЫБРАТЬ | ФизическиеЛицаУченыеСтепени.Ссылка, | ФизическиеЛицаУченыеСтепени.УченаяСтепень, | ФизическиеЛицаУченыеСтепени.ОтрасльНауки, | ФизическиеЛицаУченыеСтепени.ДипломСерияНомер, | ФизическиеЛицаУченыеСтепени.ДатаПрисужденияУченойСтепени |ИЗ | Справочник.ФизическиеЛица.УченыеСтепени КАК ФизическиеЛицаУченыеСтепени |ГДЕ | ФизическиеЛицаУченыеСтепени.Ссылка В &СписокФизЛицо»; Запрос.УстановитьПараметр(«СписокФизЛицо», Параметры.СписокФизическихЛиц.ВыгрузитьКолонку(«ФизическоеЛицо»)); Выборка = Запрос.Выполнить().Выбрать(); Пока Выборка.Следующий() Цикл Отбор = Новый ТаблицаЗначений; Отбор.Колонки.Добавить («Имя»); Отбор.Колонки.Добавить («Значение»); Отбор.Колонки.Добавить («Использование»); СтрокаОтбора = Отбор.Добавить (); СтрокаОтбора.Имя = «ФизическоеЛицо»; СтрокаОтбора.Значение = Выборка.Ссылка; СтрокаОтбора.Использование = Истина; Строки = Новый ТаблицаЗначений; Строки.Колонки.Добавить(«Ссылка»); Строки.Колонки.Добавить(«ФизическоеЛицо»); Строки.Колонки.Добавить(«УченаяСтепень»); Строки.Колонки.Добавить(«Специальность»); Строки.Колонки.Добавить(«НомерДиплома»); Строки.Колонки.Добавить(«Период»); Строка = Строки.Добавить(); Строка.ФизическоеЛицо = Выборка.Ссылка; Строка.УченаяСтепень = Выборка.УченаяСтепень; Строка.Специальность = Выборка.ОтрасльНауки; Строка.НомерДиплома = Выборка.ДипломСерияНомер; Строка.Период = Выборка.ДатаПрисужденияУченойСтепени; НаборЗаписей = Новый Структура(«Отбор, Строки»); НаборЗаписей.Отбор = Отбор; НаборЗаписей.Строки = Строки; ВыгрузитьРегистр(НаборЗаписей,,,Истина,»УченыеСтепениФизическихЛиц»); КонецЦикла;

Выгрузка данных из программы 1С: Зарплата и управление персоналом в программу 1С: Бухгалтерия 8

Настройка совместного использования данных осуществляется один раз, после чего перенос данных в 1С: Бухгалтерию 8 из программы 1С: Зарплата и управление персоналом 8 (1С: ЗУП 8) осуществляется автоматически. Следует отметить, что возможности учета в типовых решениях на базе 1С: Предприятие 8 реализованы во многих вариантах, которые очень важно отобразить при настройке переноса данных в 1С.

Связь программ 1С: ЗУП 8 и 1С: Бухгалтерии 8 осуществляется на уровне проводок. Для того, чтобы ее настроить в программе 1С: ЗУП 8 имеется специальная обработка «Выгрузка данных в бухгалтерскую программу», которая может функционировать в двух режимах:

  • для переноса кассовых операций;
  • для переноса проводок.

Перенос проводок в 1С: ЗУП 8 с помощью обработки

При переносе проводок из 1С: ЗУП 8 в 1С: Бухгалтерию 8 с использованием обработки «Выгрузка данных в бухгалтерскую программу» осуществляется перенос документа «Отражение зарплаты в регламентированном учете», который создан в 1С: ЗУП 8.

Запустить обработку можно из меню «Сервис», выбрав пункт «Обмен данными». Однако перед тем, как это сделать, необходимо определить период, за который вы хотите выгрузить проводки, выбрать путь и указать имя файла, куда будет выполнена выгрузка данных.

Перенос проводок осуществляется в программу 1С: Бухгалтерия 8 один раз в месяц после расчета заработной платы, начисления взносов, налогов и формирования всех проводок.

После того, как проводки из 1С: ЗУП 8 выгружены, в меню программы 1С: Бухгалтерия 8 «Сервис», разделе «Обмен данными с Зарплата и управление персоналом 8», выбрав пункт «Загрузка данных из конфигурации Зарплата и управление персоналом 8», необходимо указать файл созданной выгрузки и нажать кнопку «Выполнить».

Перед выгрузкой проводок из программы 1С: Зарплата и управление персоналом 8 нужно для дальнейшей корректной работы их сформировать, используя определенные настройки, учитывающие формат учета 1С: Бухгалтерии 8.

Сперва в программе 1С: Бухгалтерия 8 нужно указать в настройке параметров учета (закладка «Расчеты с персоналом»), что кадровый учет и учет расчетов заработной платы осуществляются во внешней программе. Соответственно нужно определить аналитику счета 70 либо сводно по всем сотрудникам, либо по каждому сотруднику отдельно в зависимости от требований к автоматизированной системе.

Если учетная деятельность в программе 1С: Бухгалтерия 8 ведется дольше, чем работа в программе 1С: ЗУП 8, то целесообразно выполнить выгрузку в нее «Сведения для выгрузки в новую информационную базу». Для этого необходимо в меню программы 1С: Бухгалтерия 8 «Сервис», в разделе «Обмен данными с Зарплата и управление персоналом 8» выбрать пункт «Выгрузка данных в конфигурацию Зарплата и управление персоналом».

Далее следует действовать по выше указанной схеме, а именно: указать файл для выгрузки данных.

Необходимо также обратить внимание на следующий момент: чтобы в дальнейшем в выгружать данные в 1С: Бухгалтерию 8 проводки и кассовые операции, нужно выполнить синхронизацию данных. То есть в обеих программах должны совпадать подразделения организаций. Если учет расчетов заработной платы ведется по каждому сотруднику в отдельности, то должны совпадать записи в справочниках «Физ. лица» и «Сотрудники организации».

Консультация

Рекомендуем еще статьи про 1С: Бухгалтерию 8:

  • Как обновить типовую конфигурацию 1С бухгалтерии 8?
  • Учет покупки недвижимости в 1С Бухгалтерии 8
  • Отражение продажи недвижимого имущества в 1С: Бухгалтерии 8

Вы можете получать новые материалы сайта по RSS-каналу или можете подписаться на новости 1С от Информ Актив и получать их еженедельно на Ваш e-mail .

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *